Back to overview
Downtime

Login page unavailable

Apr 05 at 09:45pm AEST
Affected services
Crew Portal

Resolved
Apr 05 at 10:20pm AEST

We've identified and pushed a fix relating to the Crew Centre authentication issue. Thanks for your patience.

Created
Apr 05 at 09:45pm AEST

Crew Centre authentication is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.